Salta al contenuto

WordPress 2.7

Questo articolo ha oltre sei mesi di vita, quindi, mi raccomando, verifica le informazioni contenute in quanto potrebbero essere ormai obsolete.

Ho installato wordpress 2.7 su due blog (su questo non ancora n.d.b.).

Su webperte e su Aruba.

L’aggiornamento dalla 2.6.3 è stato eseguito nel solito modo:

  • Backup di tutto
  • Disatttivazione plugin
  • Tema Standard
  • Cancellazioni di tutti i files eccetto htaccess,wp-config.php e la dir wp-content (ho cancellato i temi standard e default)
  • Caricamento dei nuovi file
  • Upgrade del databse

Unico problemino ho dovuto modificara il plugin simple tag altrimenti non funzionante.

Trovate in simple tags questa linea

if ( strpos($wp_version, '2.5') !== false || strpos($wp_version, '2.6') !== false  )

e modificatela così

if ( strpos($wp_version, '2.5') !== false || strpos($wp_version, '2.6') !== false  || strpos($wp_version, '2.7') !== false)

Ora funzionerà anche simple tags.

Ho immediatamente testato l’upgrade automatico del core.

Su WebPerTe bisogna avere sotto mano le credenziali ftp (come per l’aggiornamento dei plugin) e tutto è filato liscio

Su Aruba l’upgrade è andato liscio come l’olio tranne che per i permessi che si sono sputtanati con conseguente errore 500, nulla di grave sono entrato in admin.miosito.quellocheè e ho ripristinato i permessi e tutto perfettamente funzionante.

Il back end nuovo è veramente spettacolare.

Ho una newsletter che parla di WordPress

This is the archive

Iscriviti alla mia Newsletter

Published inTecnologiaWordpress

18 Comments

  1. Ciao, grazie per il post che mi sarà molto utile quando aggiornerò, ma non ho capito molto bene quella cosa dei permessi di Aruba…

  2. prova ad entrare nel pannello di amministrazione del tuo sito e troverai l’utility per ripristinare i permessi.

  3. Grazie mille, non lo trovavo 😉

  4. Ottimo, in questi giorni passerò a WebPerTe e mi fa piacere sapere che funziona l’upgrade automatico 😀 Tranne che con WP 2.7 ho molti problemi con il template 🙁

    Grazie 😀

  5. @stefano la prima cosa che devi fare appena passi a webperte è quella di rompere le palle a più non posso per farti togliere il safe_mode che è una rottura di palle mica da ridere.

  6. A bene! 😉 Non lo sapevo! Grazie mille, ma mi fanno problemi per disattivarlo?

  7. in effetti il nuovo backend e’ davvero spettacolare, non ho installato personalmente la versione 2.7 ma l’ho testata sul codex di buddypress. Hanno dato uno stile molto piu’ professionale e da vero CMS.

  8. Francesco Francesco

    Ciao, io sto avendo dei problemi con Aruba e WordPress 2.7 infatti da quando ho provato ad aggiornare alla 2.7 ottengo l’errore 500 (che si risolve ripristinando i permessi come hai indicato tu) inoltre la copia su FTP di wordpress va in timeout su alcuni file (ad esempio wordpress/xmlrpc.php). Hai avuto anche tu questo problema?

      • Francesco Francesco

        Quella è la soluzione per il problema dei permessi. Il mio problema è un altro. Io non ho usato nessun aggiornamento automatico, sto provando a copiare manualmente i file su FTP da giorni ma alcuni di questi non vengono copiati.

        • usi per caso filezilla? se si aggiorna all’ultima versione poi riprova.

          • Francesco Francesco

            No, uso Cyberduck su Mac.

            • cyberduck l’ho eliminato tempo fa perchè mi creava dei problemi in upload, prova a scaricare l’ultima verisone di filezilla.

    • per l’ftp non ho notato alcun problema

      • Francesco Francesco

        Ho provato ad utilizzare la funzione ripristina anzichè sovrascrivi nel client FTP ed ora sono riuscito ad uploadare tutto. Grazie dell’aiuto!

  9. io ho parecchi problemi di ftp

    • e cosa centra con wordpress 2.7?

Lascia un commento

Il tuo indirizzo email non sarà pubblicato. I campi obbligatori sono contrassegnati *

Questo sito usa Akismet per ridurre lo spam. Scopri come i tuoi dati vengono elaborati.

%d blogger hanno fatto clic su Mi Piace per questo: